Cambium Networks - Web UI load issues in some US regions – Incident details

Web UI load issues in some US regions

Resolved
Partial outage
Started 25 days agoLasted 40 minutes

Affected

cnMaestro

Updates
  • Resolved
    Resolved

    This incident has been resolved. Between 15:36Z and 16:20Z the web interface of cnMaestro will have been slow and in cases unavailable for users in some US locations. Cambium has a fix under test and expect to roll this out to production for cnMaestro version 5.2.5 (due December 2025)

  • Identified
    Identified

    At around 15:36Z some clusters began to lose access to the AWS cloudfront CDN, causing delays in page load times and occasionally timeouts.