Cambium Networks - Outage for some EU west cnmaestro pods (5,9,16,22,24) – Incident details

Outage for some EU west cnmaestro pods (5,9,16,22,24)

Resolved
Partial outage
Started 4 days agoLasted less than a minute

Affected

cnMaestro

Operational from 10:45 PM to 10:45 PM

EU Region

Operational from 10:45 PM to 10:45 PM

Web App, WLAN Controllers, APIs

Operational from 10:45 PM to 10:45 PM

EasyPass

Operational from 10:45 PM to 10:45 PM

MarketApps

Operational from 10:45 PM to 10:45 PM

Updates
  • Update
    UTC
    Update

    Workarounds have been put in place, and the region is fully operational

  • Resolved
    UTC
    Resolved

    Outage for some EU west pods (5,9,16,22,24)

    At around 11:43 UTC on Sunday 12 July 2026, some cnMaestro services in the EU west region began to fail due to an EC2 failure. Compounding this, automated recovery of the EC2 workloads also unavailable. AWS support are looking in to the root cause, and we will update this notice if more information becomes available. No network outages were recorded, but configuration changes and metrics collection will have failed for customers on impacted pods. Alternative recovery was completed by 01:58 UTC on Monday 13 July 2026. We apologise for any inconvenience.